跳转到主要内容

文件菜单

主界面文件菜单​

TouchGFX 设计器的主界面文件菜单由文件和帮助菜单项组成。

文件​

主界面文件菜单中的文件菜单项

打开​

点击“打开”按钮,将打开文件管理器,从这里可以导航到TouchGFX 设计器项目文件(.touchgfx)并加载文件

切换为深色主题​

Clicking the Switch to Dark theme button will change the theme of TouchGFX Designer to a dark theme.

下载​

Hovering/clicking the Download button will reveal four options for downloading packages, clicking any of these will make TouchGFX Designer download all packages of the specified type for offline use.

设置​

悬停/单击“Settings”按钮,将显示TouchGFX Designer全局设置选项,单击其中任何一个(“Check Connection”除外)将打开配置所选设置的窗口。

"Check Connection" is turned on by default and allows TouchGFX Designer to check if internet is available.

退出​

Clicking the Exit button will shutdown TouchGFX Designer.

帮助​

主界面文件菜单中的帮助菜单项

文件​

点击“文件”按钮将在您的操作系统默认浏览器中打开https://support.touchgfx.com。

问答​

点击“问&答”按钮将在您的操作系统默认浏览器中打开https://community.st.com/touchgfx。

请求功能​

点击“请求功能”按钮将在您的操作系统默认浏览器中打开https://community.st.com/s/ideazone。

键盘快捷键​

点击“键盘快捷键”按钮将在您的操作系统默认浏览器中打开https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

关于​

单击“关于”按钮将打开一个包含软件许可协议的窗口。

项目文件菜单​

TouchGFX 设计器的项目文件菜单由文件、编辑和帮助菜单项组成。

文件​

项目文件菜单中的文件菜单项

新建​

点击“新建”按钮将打开大厅,在这里可以创建新项目。

打开​

点击“打开”按钮,将打开文件管理器,从这里可以导航到TouchGFX 设计器项目文件(.touchgfx)并加载文件

保存​

点击“保存”按钮会将当前打开的项目保存到其TouchGFX 设计器项目中。
在运行模拟器、刷写至目标和生成代码时,也会保存项目。

切换为深色主题​

Clicking the Switch to Dark theme button will change the theme of TouchGFX Designer to a dark theme.

最近​

将鼠标悬停在“最近”按钮上或点击该按钮,将显示最近创建、打开或修改过的项目,点击其中的任何一个将加载该项目。

退出​

Clicking the Exit button will shutdown TouchGFX Designer.

编辑​

项目菜单中的编辑菜单项

撤销​

点击“撤消”按钮将撤消在画布视图中所做的更改。 如果没有可撤销的修改,或者当前未选中“画布视图”,则该菜单为灰色。

重做​

点击“重做”按钮将重做画布视图中所做的更改。 如果没有可重做的修改,或者当前未选中“画布视图”,则该菜单为灰色。

全选​

点击“全选”按钮将选择添加到屏幕或自定义容器的所有控件,这些控件当前在画布视图中可见。

复制​

点击“复制”按钮将当前在画布视图中选择的“控件”、“屏幕”或“自定义容器”添加到复制/粘贴缓冲区。

粘贴​

点击“粘贴”按钮,对复制/粘贴缓冲区中的小工具、屏幕或自定义容器进行粘贴。 如果没有复制对象,将无法进行粘贴。

删除​

点按“删除”按钮将删除画布视图中当前选定的控件、屏幕或自定容器。

导入GUI​

单击导入GUI按钮将打开导入GUI窗口。

TouchGFX Designer中的“导入UI”窗口

在这里,可以将UI导入当前打开的工程中。 可以从意法半导体提供的示例和演示中选择UI,或者点击“浏览”,然后选择要导入当前工程的TouchGFX Designer工程 (.touchgfx) 。

Caution
导入的UI将覆盖工程中已有的UI

代码​

项目文件菜单中的代码菜单项

生成代码​

生成代码单击“生成代码”按钮,将开始生成当前项目的代码。 如果有其他生成或编译步骤正在运行,则此按钮可能会变灰。

运行模拟器​

单击“运行模拟器”按钮,将开始编译当前项目,然后打开模拟器。 如果有其他生成或编译步骤正在运行,则此按钮可能会变灰。

程序和运行目标​

单击“程序和运行目标”按钮,将开始编译项目,随后刷写至目标。 如果有其他生成或编译步骤正在运行,则此按钮可能会变灰。

程序内部flash和运行目标​

单击“程序内部flash和运行目标”按钮将开始编译项目,然后烧录目标的内部存储器。 如果烧录目标内部指令被禁用,此按钮将为灰色。

取消​

单击“取消”按钮,将取消任何正在运行的生成或编译步骤。 当无生成或编译步骤运行时,此按钮将变灰。

打开文件​

单击“打开文件”按钮,将在文件浏览器中打开项目文件夹。

帮助​

项目文件菜单中的帮助菜单项

文件​

点击“文件”按钮将在您的操作系统默认浏览器中打开https://support.touchgfx.com。

问答​

点击“问&答”按钮将在您的操作系统默认浏览器中打开https://community.st.com/touchgfx。

请求功能​

点击“请求功能”按钮将在您的操作系统默认浏览器中打开https://community.st.com/s/ideazone。

键盘快捷键​

点击“键盘快捷键”按钮将在您的操作系统默认浏览器中打开https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

关于​

单击“关于”按钮将打开一个包含软件许可协议的窗口。