メイン・コンテンツまでスキップ

File Menu(ファイル・メニュー)

Lobby File Menu​

TouchGFX DesignerのLobby File Menuは、[File]および[Help]メニュー・アイテムで構成されます。

File(ファイル)​

Lobby File Menuの[File]メニュー・アイテム

Open​

[Open]ボタンをクリックすると、ファイル・エクスプローラが開き、TouchGFX Designerプロジェクト・ファイル(.touchgfx)に移動したり読み込んだりすることができます。

Switch to Dark theme​

[Switch to Dark theme]ボタンをクリックすると、TouchGFX Designerの表示モードがダーク・モードに変更されます。

Download​

[Download]ボタンにカーソルを合わせるか、もしくはクリックすると、パッケージのダウンロードに関する4つのオプションが表示されます。これらのいずれかをクリックすると、オフラインで使用するために、指定した種類のすべてのパッケージがTouchGFX Designerによってダウンロードされます。

Settings​

[Settings]ボタンにカーソルを合わせるか、もしくはクリックすると、TouchGFX Designerのグローバル設定を設定するためのオプションが表示されます。これらのいずれか([Check Connection]以外)をクリックすると、選択した設定を構成するのに使用されるウィンドウが開きます。

[Check Connection]はデフォルトでオンになっており、TouchGFX Designerがインターネット接続が可能かをチェックします。

Exit​

[Exit]ボタンをクリックすると、TouchGFX Designerがシャットダウンされます。

Help(ヘルプ)​

Lobby File Menuの[Help]メニュー・アイテム

Documentation​

[Documentation]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://support.touchgfx.comが開きます。

Q&A​

[Q&A]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://community.st.com/touchgfxが開きます。

Request Feature​

[Request Feature]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://community.st.com/s/ideazoneが開きます。

Keyboard Shortcuts​

[Keyboard Shortcuts]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcutsが開きます。

About​

[About]ボタンをクリックすると、ソフトウェア使用許諾契約を含むウィンドウが開きます。

Project File Menu​

TouchGFX DesignerのProject File Menuは、[File]、[Edit]、[Help]メニュー・アイテムで構成されます。

File(ファイル)​

Project File Menuの[File]メニュー・アイテム

New​

[New]ボタンをクリックすると、Lobbyが表示されます。ここで新しいプロジェクトを作成できます。

Open​

[Open]ボタンをクリックすると、ファイル・エクスプローラが開き、TouchGFX Designerプロジェクト・ファイル(.touchgfx)に移動したり読み込んだりすることができます。

Save​

[Save]ボタンをクリックすると、現在開いているプロジェクトがTouchGFX Designerプロジェクトに保存されます。
シミュレータの実行中、ターゲットへのFlash書込み中、コードの生成中でもプロジェクトは保存されます。

Switch to Dark theme​

[Switch to Dark theme]ボタンをクリックすると、TouchGFX Designerの表示モードがダーク・モードに変更されます。

Recent​

[Recent]ボタンにカーソルを合わせるかクリックすると、直近に作成、オープン、または変更されたプロジェクトが表示され、このいずれかをクリックするとそのプロジェクトが読み込まれます。

Exit​

[Exit]ボタンをクリックすると、TouchGFX Designerがシャットダウンされます。

Edit(編集)​

Project File Menuの[Edit]メニュー・アイテム

Undo​

[Undo]ボタンをクリックすると、Canvas Viewで行われた変更が元に戻されます。 元に戻す変更が存在しない場合や、Canvas Viewが現在選択されていない場合は、このボタンはグレー表示になります。

Redo​

[Redo]ボタンをクリックすると、Canvas Viewで行われた変更がやり直されます。 やり直す変更が存在しない場合や、Canvas Viewが現在選択されていない場合、このボタンはグレー表示になります。

Select All​

[Select All]ボタンをクリックすると、Canvas Viewに現在表示されているスクリーンまたはカスタム・コンテナに追加されたすべてのウィジェットが選択されます。

Copy​

[Copy]ボタンをクリックすると、Canvas Viewで現在選択されているウィジェット、スクリーン、またはカスタム・コンテナが、コピー / 貼り付けバッファに追加されます。

Paste​

[Paste]ボタンをクリックすると、コピー / 貼り付けバッファ内に現在存在するウィジェット、スクリーン、またはカスタム・コンテナが貼り付けられます。 コピーされたオブジェクトが存在しない場合、Pasteは使用できません。

Delete​

[Delete]ボタンをクリックすると、Canvas Viewで現在選択されているウィジェット、スクリーン、またはカスタム・コンテナが削除されます。

Import GUI​

[Import GUI]ボタンをクリックすると、[Import GUI]ウィンドウが開きます。

TouchGFX DesignerのImport UIウィンドウ

ここでは、現在開いているプロジェクトにUIをインポートできます。 UIはSTが提供するサンプルやデモから選択できます。または、'Browse'をクリックして、現在のプロジェクトにインポートするTouchGFX Designerプロジェクト(.touchgfx)を選択することもできます。

Caution
UIをインポートすると、プロジェクトの既存のUIが上書きされます。

Code(コード)​

Project File Menuの[Code]メニュー・アイテム

Generate Code​

[Generate Code]ボタンをクリックすると、現在のプロジェクトのコードの生成が開始されます。 他の生成ステップやコンパイル・ステップが実行されている場合は、このボタンはグレー表示されます。

Run Simulator​

[Run Simulator]ボタンをクリックすると、現在のプロジェクトのコンパイルが開始され、その後シミュレータが開きます。 他の生成ステップやコンパイル・ステップが実行されている場合は、このボタンはグレー表示されます。

Program and Run Target​

Run Target
[Program and Run Target]ボタンをクリックすると、プロジェクトのコンパイルが開始され、その後ターゲットに書き込まれます。 他の生成ステップやコンパイル・ステップが実行されている場合は、このボタンはグレー表示されます。

Program Internal Flash and Run Target​

[Program Internal Flash and Run Target]ボタンをクリックすると、プロジェクトのコンパイルが開始され、その後ターゲットの内部メモリが書き込まれます。 このボタンは、Flash Target Internal Commandが無効化されている場合は、グレー表示されます。

Cancel​

[Cancel]ボタンをクリックすると、実行中の生成ステップやコンパイル・ステップがキャンセルされます。 このボタンは、実行中の生成ステップやコンパイル・ステップがない場合にはグレー表示されます。

Open Files​

[Open Files]ボタンをクリックすると、ファイル・ブラウザでプロジェクト・フォルダが開きます。

Help(ヘルプ)​

Project File Menuの[Help]メニュー・アイテム

Documentation​

[Documentation]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://support.touchgfx.comが開きます。

Q&A​

[Q&A]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://community.st.com/touchgfxが開きます。

Request Feature​

[Request Feature]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://community.st.com/s/ideazoneが開きます。

Keyboard Shortcuts​

[Keyboard Shortcuts]ボタンをクリックすると、お使いのオペレーティング・システムのデフォルト・ブラウザでhttps://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcutsが開きます。

About​

[About]ボタンをクリックすると、ソフトウェア使用許諾契約を含むウィンドウが開きます。