주요 내용으로 건너뛰기

파일 메뉴

로비 파일 메뉴​

TouchGFX Designer의 로비 파일 메뉴는 File 및 Help 메뉴 항목으로 구성되어 있습니다.

File​

로비 파일 메뉴의 File 메뉴 항목

열기​

Open 버튼을 클릭하면 파일 탐색기가 열려 TouchGFX Designer 프로젝트 파일(.touchgfx)로 이동해 로드할 수 있습니다.

다크 테마로 전환​

Switch to Dark Theme 버튼을 클릭하면 TouchGFX Designer의 테마가 다크 테마로 바뀝니다.

다운로드​

Download 버튼에 마우스를 갖다 대거나 클릭하면 패키지 다운로드를 위한 네 가지 옵션이 표시되며, 이 중 하나를 클릭하면 TouchGFX Designer가 오프라인 사용을 위해 지정된 유형의 모든 패키지를 다운로드하게 됩니다.

설정​

Setting 버튼에 마우스를 갖다 대거나 클릭하면 TouchGFX Designer의 전역 설정을 위한 옵션이 표시되며 "Check Connection"을 제외하고 이 중 하나를 클릭하면 선택한 설정을 구성하는 데 사용되는 창이 열립니다.

"Check Connection"은 기본적으로 켜져 있으므로 TouchGFX Designer가 인터넷이 이용 가능한 상태인지 확인할 수 있습니다.

종료​

Exit 버튼을 클릭하면 TouchGFX Designer가 종료됩니다.

Help​

로비 파일 메뉴의 Help 메뉴 항목

문서​

Documentation 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://support.touchgfx.com이 열립니다.

Q&A​

Q&A 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://community.st.com/touchgfx가 열립니다.

기능 요청​

Request Feature 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://community.st.com/s/ideazone이 열립니다.

키보드 단축키​

Keyboard Shortcuts 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts이 열립니다.

정보​

About 버튼을 클릭하면 소프트웨어 라이선스 계약이 포함된 창이 열립니다.

프로젝트 파일 메뉴​

TouchGFX Designer의 프로젝트 파일 메뉴는 File, Edit 및 Help 메뉴 항목으로 구성되어 있습니다.

File​

프로젝트 파일 메뉴의 File 메뉴 항목

신규​

New 버튼을 클릭하면 로비가 열리고, 여기서 새로운 프로젝트를 생성할 수 있습니다.

열기​

Open 버튼을 클릭하면 파일 탐색기가 열려 TouchGFX Designer 프로젝트 파일(.touchgfx)로 이동해 로드할 수 있습니다.

저장​

Save 버튼을 클릭하면 현재 열려 있는 프로젝트가 TouchGFX Designer 프로젝트로 저장됩니다.
그 밖에 시뮬레이터를 실행할 때, 대상에 플래싱할 때, 코드를 생성할 때도 프로젝트가 저장됩니다.

다크 테마로 전환​

Switch to Dark Theme 버튼을 클릭하면 TouchGFX Designer의 테마가 다크 테마로 바뀝니다.

최근​

Recent 버튼에 마우스를 갖다 대거나 클릭하면 최근에 생성했거나, 열었거나, 변경한 프로젝트가 표시되며, 이중 하나를 클릭하면 해당 프로젝트가 로드됩니다.

종료​

Exit 버튼을 클릭하면 TouchGFX Designer가 종료됩니다.

Edit​

프로젝트 파일 메뉴의 Edit 메뉴 항목

실행 취소​

Undo 버튼을 클릭하면 Canvas View에서 변경한 내용이 실행 취소됩니다. 실행 취소할 변경 내용이 없거나 Canvas View가 선택되어 있지 않을 경우 이 버튼은 회색으로 비활성화됩니다.

다시 실행​

Redo 버튼을 클릭하면 Canvas View에서 변경한 내용이 다시 실행됩니다. 재실행할 변경 내용이 없거나 Canvas View가 선택되어 있지 않을 경우 이 버튼은 회색으로 비활성화됩니다.

모두 선택​

Select All 버튼을 클릭하면 현재 Canvas View에서 보이는 스크린 또는 커스텀 컨테이너에 추가된 위젯이 모두 선택됩니다.

복사​

Copy 버튼을 클릭하면 현재 Canvas View에서 선택된 위젯, 스크린 또는 커스텀 컨테이너가 복사/붙여넣기 버퍼에 추가됩니다.

붙여넣기​

Paste 버튼을 클릭하면 현재 복사/붙여넣기 버퍼에 있는 위젯, 스크린 또는 커스텀 컨테이너를 붙여 넣습니다. 복사한 객체가 없으면 Paste 버튼이 활성화되지 않습니다.

삭제​

Delete 버튼을 클릭하면 현재 Canvas View에서 선택된 위젯, 스크린 또는 커스텀 컨테이너가 삭제됩니다.

GUI 가져오기​

Import Gui 버튼을 클릭하면 Import GUI 창이 열립니다.

TouchGFX Designer에서 Import UI 창이 열린 모습

여기서 현재 열려 있는 프로젝트에 UI를 가져올 수 있습니다. UI는 STMicroelectronics에서 제공하는 Examples와 Demos에서 선택하거나, 혹은 'Browse'를 클릭하여 현재 프로젝트로 가져올 TouchGFX Designer 프로젝트(.touchgfx)를 선택할 수 있습니다.

Caution
UI를 가져오면 프로젝트에 이미 존재하는 UI를 덮어쓰게 됩니다.

코드​

프로젝트 파일 메뉴의 Code 메뉴 항목

코드 생성​

Generate Code 버튼을 클릭하면 현재 프로젝트의 코드 생성이 시작됩니다. 실행 중인 다른 생성 또는 컴파일 단계가 있는 경우에는 이 버튼이 회색으로 비활성화됩니다.

시뮬레이터 실행​

Run Simulator 버튼을 클릭하면 현재 프로젝트의 컴파일이 시작되고 이후에 Simulator가 열립니다. 실행 중인 다른 생성 또는 컴파일 단계가 있는 경우에는 이 버튼이 회색으로 비활성화됩니다.

Program and Run Target​

Program and Run Target 버튼을 클릭하면 프로젝트의 컴파일이 시작되고 이후에 대상에 플래싱이 수행됩니다. 실행 중인 다른 생성 또는 컴파일 단계가 있는 경우에는 이 버튼이 회색으로 비활성화됩니다.

Program Internal Flash and Run Target​

Program Internal Flash and Run Target 버튼을 클릭하면 프로젝트의 컴파일이 시작되고 이후에 대상의 내부 메모리 플래싱이 수행됩니다. Flash Target Internal 명령이 비활성화된 경우 이 버튼이 회색으로 표시됩니다.

취소​

Cancel 버튼을 클릭하면 실행 중인 생성 또는 컴파일 단계가 취소됩니다. 실행 중인 생성 또는 컴파일 단계가 없는 경우에는 이 버튼이 회색으로 비활성화됩니다.

파일 열기​

Open Files 버튼을 클릭하면 파일 브라우저에서 프로젝트 폴더가 열립니다.

Help​

프로젝트 파일 메뉴의 Help 메뉴 항목

문서​

Documentation 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://support.touchgfx.com이 열립니다.

Q&A​

Q&A 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://community.st.com/touchgfx가 열립니다.

기능 요청​

Request Feature 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://community.st.com/s/ideazone이 열립니다.

키보드 단축키​

Keyboard Shortcuts 버튼을 클릭하면 운영 체제 기본 브라우저에서 https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts이 열립니다.

정보​

About 버튼을 클릭하면 소프트웨어 라이선스 계약이 포함된 창이 열립니다.