跳轉到主要內容

檔案選單

主介面檔案選單​

TouchGFX Designer的主介面檔案選單包含File(檔案)及Help(說明)選單項目。

File (文件)​

主介面檔案選單的File(檔案)選單項目

Open (開啟)​

點擊Open (開啟)按鈕,將開啟檔案總管,您可從此導覽到TouchGFX Designer專案檔案(.touchgfx)並將其載入

Switch to Dark theme (切換為深色主題)​

點擊Switch to Dark theme (切換為深色主題)按鈕,可將TouchGFX Designer的主題切換為深色主題。

Download (下載)​

將滑鼠停在/點擊Recent (最近)按鈕,將顯示四個選項用於下載套件,點擊任何一個選項都會讓TouchGFX Designer下載指定類型的所有套件以便離線使用。

Settings (設定)​

將滑鼠停在/點擊Recent (最近)按鈕,將顯示選項用於設定TouchGFX Designer's global settings (TouchGFX Designer全域設定),點擊任何選項將開啟視窗,用於設定所選取的設定。

Exit (退出)​

點擊Exit (退出)按鈕將關閉TouchGFX Designer。

Help (幫助)​

主介面檔案選單的Help(說明)選單項目

Documentation (文字)​

點擊Documentation (文字)按鈕將在作業系統的預設瀏覽器開啟網址https://support.touchgfx.com。

Q&A (問與答)​

點擊Q&A(問與答)按鈕將在作業系統的預設瀏覽器開啟網址https://community.st.com/touchgfx。

Request Feature (要求功能)​

點擊Request Feature (要求功能)按鈕將在作業系統的預設瀏覽器開啟網址https://community.st.com/s/ideazone。

Keyboard Shortcuts (鍵盤快速鍵)​

點擊Keyboard Shortcuts (鍵盤快速鍵)按鈕將在作業系統的預設瀏覽器開啟網址https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

About (關於)​

點擊About (關於)按鈕將開啟包含軟體授權協議的視窗。

專案檔案選單​

TouchGFX Designer的專案檔案選單包含File(檔案)、Edit(編輯)和Help(說明)選單項目。

File (文件)​

專案檔案選單的File(檔案)選單項目

New (新建)​

點擊New (新建)按鈕將開啟Lobby (主介面),可在其中建立新專案。

Open (開啟)​

點擊Open (開啟)按鈕,將開啟檔案總管,您可從此導覽到TouchGFX Designer專案檔案(.touchgfx)並將其載入

Save (儲存)​

點擊Save (儲存)按鈕會將目前開啟的專案儲存至其TouchGFX Designer專案中。
執行模擬器、燒錄至目標及產生程式碼時也會儲存專案。

Switch to Dark theme (切換為深色主題)​

點擊Switch to Dark theme (切換為深色主題)按鈕,可將TouchGFX Designer的主題切換為深色主題。

Recent (最近)​

將滑鼠停在/點擊Recent(最近)按鈕,將顯示最近建立、開啟或修改的專案,點擊任何一個選項將載入該專案。

Exit (退出)​

點擊Exit (退出)按鈕將關閉TouchGFX Designer。

Edit (編輯)​

專案檔案選單的Edit(編輯)選單項目

Undo (復原)​

點擊Undo (復原)按鈕將復原在畫布視圖進行的變更。 如果沒有可撤銷的修改,或者當前未選中“畫布視圖”,則該按鈕為灰色。

Redo (重做)​

點擊Redo (重做)按鈕將重做在畫布視圖進行的變更。 如果沒有可重做的修改,或者當前未選中“畫布視圖”,則該按鈕為灰色。

Select All (全選)​

點擊Select All (全選)按鈕將選取目前畫布視圖可見螢幕或客製容器中所有新增的小工具。

Copy (複製)​

點擊Copy (複製)按鈕會將目前在畫布視圖選取的小工具、螢幕或客製容器新增至複製/貼上緩衝區。

Paste (貼上)​

點擊Paste (貼上)按鈕將會貼上目前位在複製/貼上緩衝區的小工具、螢幕或客製容器。 如果沒有複製物件,將無法進行貼上。

Delete (刪除)​

點擊Delete (刪除)按鈕將會刪除目前在畫布視圖選取的小工具、螢幕或客製容器。

Import GUI (匯入GUI)​

點擊Import GUI (匯入GUI)按鈕將開啟Import GUI (匯入GUI)視窗。

TouchGFX Designer中的“導入UI”視窗

在這裡,可以將UI匯入當前打開的專案中。 可以從STMicroelectronics提供的範例中選擇UI,或者點擊“Browse”,然後選擇要匯入當前專案的TouchGFX Designer專案(.touchgfx)。

Caution
匯入UI將覆蓋專案中已有的UI

Code(程式碼)​

專案檔案選單的Code(程式碼)選單項目

Generate Code (產生程式碼)​

點擊Generate Code (產生程式碼)按鈕將開始產生目前專案的程式碼。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Run Simulator (執行模擬器)​

點擊Run Simulator (執行模擬器)按鈕將開始編譯目前專案,然後開啟Simulator (模擬器)。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Program and Run Target (編程及執行目標)​

點擊Program and Run Target (編程及執行目標)按鈕將開始編譯專案,然後將其燒錄至目標。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Program Internal Flash and Run Target (編程內部Flash及執行目標)​

點擊Program Internal Flash and Run Target (編程內部Flash及執行目標)按鈕將開始編譯專案,然後燒錄目標的內部記憶體。 如果停用Flash Target Internal Command (Flash目標內部指令),此按鈕就會變成灰色無法使用。

Cancel (取消)​

點擊Cancel (取消)按鈕將取消任何執行中的產生或編譯步驟。 如果沒有執行中的產生或編譯步驟,此按鈕會變成灰色無法使用。

Open Files (開啟檔案)​

點擊Open Files (開啟檔案)按鈕將在檔案瀏覽器開啟專案資料夾。

Help (幫助)​

專案檔案選單的Help(說明)選單項目

Documentation (文字)​

點擊Documentation (文字)按鈕將在作業系統的預設瀏覽器開啟網址https://support.touchgfx.com。

Q&A (問與答)​

點擊Q&A(問與答)按鈕將在作業系統的預設瀏覽器開啟網址https://community.st.com/touchgfx。

Request Feature (要求功能)​

點擊Request Feature (要求功能)按鈕將在作業系統的預設瀏覽器開啟網址https://community.st.com/s/ideazone。

Keyboard Shortcuts (鍵盤快速鍵)​

點擊Keyboard Shortcuts (鍵盤快速鍵)按鈕將在作業系統的預設瀏覽器開啟網址https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

About (關於)​

點擊About (關於)按鈕將開啟包含軟體授權協議的視窗。