跳轉到主要內容

檔案選單

主介面檔案選單​

TouchGFX Designer的主介面檔案選單包含File(檔案)及Help(說明)選單項目。

File (文件)​

主介面檔案選單的File(檔案)選單項目

Open (打開)
點擊“Open”按鈕,將打開檔案管理員,從這裡可以導航到TouchGFX Designer專案檔案(.touchgfx)並載入檔案。

Switch to Dark theme (切換至深色模式)
點擊"Switch to Dark theme"可將 TouchGFX Designer 的主題切換成深色模式。

Download(下載)
將滑鼠停在/點擊Recent(最近)按鈕,將顯示四個選項用於下載套件,點擊任何一個選項都會讓TouchGFX Designer下載指定類型的所有套件以便離線使用。

Settings(設定)
將滑鼠停在/點擊Recent(最近)按鈕,將顯示選項用於設定TouchGFX Designer's global settings(TouchGFX Designer全域設定),點擊任何選項將開啟視窗,用於設定所選取的設定。

Exit (退出)
點擊“Exit ”按鈕,將關閉TouchGFX Designer。

Help (幫助)​

主介面檔案選單的Help(說明)選單項目

Documentation (文件)
點擊“Documentation ”按鈕將在作業系統的預設流覽器中打開網址https://support.touchgfx.com。

Q&A (問與答)
點擊“Q&A”按鈕將在作業系統的預設流覽器中打開網址https://community.st.com/touchgfx。

Request Feature (請求功能)
點擊“Request Feature”按鈕將在作業系統的預設流覽器中打開網址https://community.st.com/s/ideazone。

Keyboard Shortcuts (鍵盤快速鍵)
點擊“Keyboard Shortcuts”按鈕將在作業系統的預設流覽器中打開網址https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

About (關於)
點擊“About”按鈕,將打開包含“軟體授權合約”的視窗。

專案檔案選單​

TouchGFX Designer的專案檔案選單包含File(檔案)、Edit(編輯)和Help(說明)選單項目。

File (文件)​

專案檔案選單的File(檔案)選單項目

New (新建)
點擊“New ”按鈕,將打開啟動視窗,在這裡可以創建新的專案。

Open (打開)
點擊“Open”按鈕,將打開檔案管理員,從這裡可以導航到TouchGFX Designer專案檔案(.touchgfx)並載入檔案。

Save (保存)
點擊“Save”按鈕,可將當前打開的專案保存到其TouchGFX Designer專案中。
在運行模擬器、快閃記憶體到目標硬體和生成程式碼時也會保存專案。

Switch to Dark theme (切換至深色模式)
點擊"Switch to Dark theme"可將 TouchGFX Designer 的主題切換成深色模式。

Recent (最近使用)
將滑鼠停在“Recent”按鈕上或點擊該按鈕,將顯示最近創建、打開或修改過的專案,點擊其中的任何一個將載入該專案。

Exit (退出)
點擊“Exit ”按鈕,將關閉TouchGFX Designer。

Edit (編輯)​

專案檔案選單的Edit(編輯)選單項目

Undo (撤銷)
點擊“Undo”按鈕,將撤銷在畫布視圖中所做的修改。 如果沒有可撤銷的修改,或者當前未選中“畫布視圖”,則該按鈕為灰色。

Redo (重做)
點擊“Redo”按鈕,將重做在畫布視圖中所做的修改。 如果沒有可重做的修改,或者當前未選中“畫布視圖”,則該按鈕為灰色。

Select All (全選)
點擊“Select All”按鈕,可將添加到畫布視圖中當前顯示的螢幕或自訂容器的所有小工具全部選中。

Copy (複製)
點擊“Copy”按鈕,將畫布視圖中當前選中的小工具、螢幕或自訂容器添加到複製/貼上緩衝區。

Paste (貼上)
點擊“Paste”按鈕,對複製/貼上緩衝區中的小工具、螢幕或自訂容器進行貼上。 如果沒有複製物件,將無法進行貼上。

Delete (刪除)
點擊“Delete”按鈕,將刪除畫布視圖中當前選中的小工具、螢幕或自訂容器。

Import GUI (匯入GUI)
點擊“Import GUI”按鈕,將打開“匯入GUI”視窗。

TouchGFX Designer中的“導入UI”視窗

在這裡,可以將UI匯入當前打開的專案中。 可以從STMicroelectronics提供的範例中選擇UI,或者點擊“Browse”,然後選擇要匯入當前專案的TouchGFX Designer專案(.touchgfx)。

Caution
匯入UI將覆蓋專案中已有的UI

Code(程式碼)​

專案檔案選單的Code(程式碼)選單項目

Generate Code(產生程式碼)
點擊Generate Code(產生程式碼)按鈕將開始產生目前專案的程式碼。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Run Simulator(執行模擬器)
點擊Run Simulator(執行模擬器)按鈕將會開始編譯目前專案,然後開啟Simulator(模擬器)。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Run Target(執行目標)
點擊Run Target(執行目標)按鈕將開始編譯專案,然後以Flash送往目標。 如果正在執行其他產生或編譯步驟,此按鈕可能會變成灰色無法使用。

Cancel(取消)
點擊Cancel(取消)按鈕將取消任何執行中的產生或編譯步驟。 如果沒有執行中的產生或編譯步驟,此按鈕會變成灰色無法使用。

Open Files(開啟檔案)
點擊Open Files(開啟檔案)按鈕將在檔案瀏覽器開啟專案資料夾。

Help (幫助)​

專案檔案選單的Help(說明)選單項目

Documentation (文件)
點擊“Documentation ”按鈕將在作業系統的預設流覽器中打開網址https://support.touchgfx.com。

Q&A (問與答)
點擊“Q&A”按鈕將在作業系統的預設流覽器中打開網址https://community.st.com/touchgfx。

Request Feature (請求功能)
點擊“Request Feature”按鈕將在作業系統的預設流覽器中打開網址https://community.st.com/s/ideazone。

Keyboard Shortcuts (鍵盤快速鍵)
點擊“Keyboard Shortcuts”按鈕將在作業系統的預設流覽器中打開網址https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/keyboard-shortcuts。

About (關於)
點擊“About”按鈕,將打開包含“軟體授權合約”的視窗。